Back to overview
Maintenance
Database upgrade
Jan 27 at 10:30am GMT
–
Jan 27 at 11:52am GMT
Affected services
Game servers
Resolved
Jan 27 at 11:52am GMT
Maintenance has been completed, enjoy the game!
Affected services
Created
Jan 27 at 10:30am GMT
We’re performing essential updates to keep the game running smoothly.
Affected services