Back to overview
Downtime

Players cannot login

May 6, 2026 at 10:30pm UTC
Affected services
Game servers

Resolved
May 7, 2026 at 2:43am UTC

The issue has been resolved. We are very sorry for the inconvenience. Enjoy Avakin!

Created
May 6, 2026 at 10:30pm UTC

We are investigating issues preventing players from logging into Avakin Life.